Benutzer:MathiasMahnke/Debian Buster 2019: Unterschied zwischen den Versionen

Aus Opennet
Wechseln zu: Navigation, Suche
(Status)
(Status)
Zeile 21: Zeile 21:
 
* [[Server/crimson]] -  
 
* [[Server/crimson]] -  
 
* [[Server/goat]] - Erledigt, 2019/07/25 -- offen: buildbot-web sowie Dev2 Cert-Login prüfen
 
* [[Server/goat]] - Erledigt, 2019/07/25 -- offen: buildbot-web sowie Dev2 Cert-Login prüfen
* [[Server/haruka]] - In Arbeit, 2019/09/10 -- offen: postfix backwards comp, /etc/logrotate.d/rsyslog, /etc/nagios/nrpe.cfg, /etc/openvpn/update-resolv-conf, alternatives iptables, Workaround week cert openvpn
+
* [[Server/haruka]] - Erledigt, 2019/09/10 -- offen: postfix backwards comp, /etc/logrotate.d/rsyslog, /etc/nagios/nrpe.cfg, /etc/openvpn/update-resolv-conf, Workaround week cert openvpn
 
* [[Server/heartofgold]] -  
 
* [[Server/heartofgold]] -  
 
* [[Server/hikaru]] - Erledigt, 2019/07/23
 
* [[Server/hikaru]] - Erledigt, 2019/07/23

Version vom 11. September 2019, 04:36 Uhr

Status: Offen.

Debian Buster Update Status der Opennet Server - Debian Release von 07/2019.

Status

Virtualisierungsserver:

Gateway-Server:

  • Server/erina - Kompatibilität bei MyLoc/Webtropia angefragt, 2019/07/26 -- Wechsel auf neuen Vertrag?
  • Server/subaru - Erledigt, 2019/09/02
  • Server/gai - Erledigt, 2019/08/30
  • Server/megumi - Kompatibilität bei Strato angefragt, 2019/07/26

Dienste-Server:

Sonstige Server

Buster Update Besonderheiten

  • Ferm, Wechsel iptables-legacy auf iptables-nft -- gelöst via Ansible
  • PostgreSql, sudo -u postgres reindexdb --all -- gelöst, scheinbar bereits beim Upgrade erledigt
  • LURKS2?
  • Rückbau Opennet Apt Repo? (GPG Error)
  • Fehlermeldung dpkg: warning: unable to delete old directory '/etc/init': Directory not empty, Ursache Paket munin-node
  • Fehlermeldung locale: Kann LC_ALL nicht auf die Standard-Lokale einstellen: Datei oder Verzeichnis nicht gefunden, Ursache LANGUAGE Variable? -- gelöst via Ansible
  • Backup schlägt fehl, rsync wird per Autoremove entfernt -- gelöst via Ansible
  • ircd-hybrid startet nicht, https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=932774 -- gelöst, benötigt nun zwingend wieder eine dhparam.pem Datei
  • MediaWiki 1.27 -> 1.31 (PlatformSettings.php, CodeEditor, MultimediaViewer, Timeless Skin, New wgUseFileCache Cache) -- gelöst via Ansible
  • Buildbot, Upgrade automatisch per buildbot upgrade-master, Hinweise:
 If upgrading from a 0.8.x version, all master instances in
 /var/lib/buildbot/masters must be manually migrated.
 The new Buildbot web dashboard cannot be integrated into Debian yet because
 of policy violation (See: #883529). In the meantime, it can be installed
 with ``pip3 install buildbot-www.
 Buildbot master instances can now be managed as systemd services.
 ..
 Buildbot master instance in /var/lib/buildbot/masters/public_html has been created with a 0.x version and cannot be automatically upgraded.
 Buildbot master instance in /var/lib/buildbot/masters/templates has been created with a 0.x version and cannot be automatically upgraded.
 Please see buildbot(7) for instructions.
  • uwsgi: Unix sockets are now readable by www-data by default, (option chown-socket),independent of runtime user/group.
  • Wechsel PostgreSql 9 nach 11 -- gelöst, nach Howto:
pg_dropcluster 11 main --stop
pg_upgradecluster 9.6 main
... prüfen ...
 pg_dropcluster 9.6 main
  • Postfix 3.4.5
postfix: Postfix is running with backwards-compatible default settings 
postfix: See http://www.postfix.org/COMPATIBILITY_README.html for details
postfix: To disable backwards compatibility use "postconf compatibility_level=2" and "postfix reload"
Meine Werkzeuge
Namensräume

Varianten
Aktionen
Start
Opennet
Kommunikation
Karten
Werkzeuge