Projekt HRO

Aus Opennet
Wechseln zu: Navigation, Suche

Inhaltsverzeichnis

Info

Hro.gif

Es besteht eine Zusammenarbeit mit der Hansestadt Rostock (HRO). Es beruht auf einem Bürgerschaftsbeschluss von 2015 und der Zusammenarbeit mit der Verwaltung. Im Fokus steht dabei die gemeinsame Arbeit bei Flüchtlingsunterkünften (seit 2015), den Schulen (seit vielen Jahren) sowie der Unterstützung von Gastzugängen für Bürgerinnen u. Bürgern. Es gibt seit 2016 eine gemeinsame Vernetzung auf LWL/VLAN Basis. Ein Großteil der Zusammenarbeit befindet sich im Planungstatus.

Status

AP2.244 - vor 55 Sekunden, Up: , Load: , VPN: gw / up
AP2.250 - vor 55 Sekunden, Up: 5636846.24, Load: 1.82 1.41 1.11, VPN: gw / up
AP2.251 - vor 55 Sekunden, Up: , Load: , VPN: gw / up
AP2.252 - vor 55 Sekunden, Up: , Load: , VPN: gw / up
AP2.253 - vor 55 Sekunden, Up: , Load: , VPN: gw / up

Statistiken

Beratung / Indoor

on_captive_portal_users-week.png on_captive_portal_traffic-week.png

Gäste / Öffentlich

on_captive_portal_users-week.png on_captive_portal_traffic-week.png

Schulen Zentrum

on_captive_portal_users-week.png on_captive_portal_traffic-week.png

Schulen Nordost

on_captive_portal_users-week.png on_captive_portal_traffic-week.png

Schulen Nordwest

on_captive_portal_users-week.png on_captive_portal_traffic-week.png

Historie

  • 03. Juni 2015 - durch Initiative von Matthias Meisser Beschluss der Rostocker Bürgerschaft zur Unterstützung der Opennet Initiative nach Antrag von DIE.LINKE (siehe Blogbeitrag)
  • 21. Januar 2016 - durch Kontakt von Christian Wedell Anfrage der Hansestadt IT (IuK) zur konkreten technischen Kooperation (gemeinsames WLAN, Ausbau Schulzusammenarbeit)
  • Frühjahr/Sommer 2016 - div. Projektreffen mit Hansestadt IT durch Christian, Johannes und Mathias sowie Opennet interne Planungstreffen bis zum Herbst
  • 30. November 2016 - Thomas Mundt und Mathias Mahnke; finale OLSR Mesh Anbindung der Hansestadt ("hro-mesh") in Projekt AE22, OLSR Routing via Opennet Server/aqua (siehe Blogbeitrag)
  • 17. Dezember 2016 - Lars und Mathias installieren das redundante OLSR Routing, nun auch via Opennet Server/tamago
  • 18. Dezember 2016 - Mathias stellt die virtuellen Gateways / Captive Portal APs AP2.244, AP2.250, AP2.251, AP2.252, AP2.253 bereit

Aktueller Stand

Geräteübersicht:

  • AP2.244 als Gateway / Captive Portal User-AP für Beratungsräume WLAN (Rathaus, IT, weitere Beratungsräume); an allen Standorten "opennet-initiative.de" (WPA2-Personal)
  • AP2.250 als Gateway / Captive Portal User-AP für Gäste WLAN (Bibliothek, VHS, Neptunschwimmhalle, VTR, Konservatorium), an ausgewählten Standorten "join.opennet-initiative.de" (Offen)
  • AP2.251 als Gateway / Captive Portal User-AP für Schulen Zentrum WLAN (Borwinschule, ISG, Danziger Str., Jenaplan), nach Bedarf WPA2-Personal für Lehrer / separate SSID offen nach Bedarf / Projektwoche
  • AP2.252 als Gateway / Captive Portal User-AP für Schulen Nordost WLAN
  • AP2.253 als Gateway / Captive Portal User-AP für Schulen Nordwest WLAN

Verkablung:

  • Anbindung zwischen HRO und Opennet erfolgt am Projekt AE22. Details zu Patchfeldern und Switchen dort.

Vereinbarte VLAN IDs:

  • 350 hro-beratung Opennet Beratung 172.16.10.1/23 + DHCP/NAT
  • 351 hro-gaeste Opennet Gäste 172.16.10.1/23 + DHCP/NAT
  • 352 hro-schzentrum Opennet Schulen Zentrum 172.16.10.1/23 + DHCP/NAT
  • 353 hro-schnordost Opennet Schulen Nordost 172.16.10.1/23 + DHCP/NAT
  • 354 hro-schnordwest Opennet Schulen Nordwest 172.16.10.1/23 + DHCP/NAT
  • 362 hro-mesh Opennet Mesh 192.168.0.0/16 + OLSR

SSIDs:

  • join.opennet-initiative.de (Open, 2.4 u. 5 Ghz), via WLAN Controller HRO (Zuordnung zu AP Gruppen je nach Standort)

Musterkonfigurationen

VLAN Konfiguration auf Switch:

vlan 350  
  name hro-beratung
vlan 351
  name hro-gaeste
vlan 352  
  name hro-schzentrum
vlan 353
  name hro-schnordost
vlan 354
  name hro-schnordwest
vlan 362
  name hro-mesh
int <Uplink-Port>
  description hro Uplink
  switchport trunk encapsulation dot1q
  switchport trunk allowed vlan 350-354,362
  switchport mode trunk
  spanning-tree portfast
  no shutdown
  cdp enable

Interfacekonfiguration auf Opennet Servern:

auto hro-beratung
iface hro-beratung inet manual
       pre-up ip link add link eth1 name hro-beratung type vlan id 350
       up ip link set hro-beratung up
       post-down ip link del hro-beratung
auto hro-gaeste
iface hro-gaeste inet manual
       pre-up ip link add link eth1 name hro-gaeste type vlan id 351
       up ip link set hro-gaeste up
       post-down ip link del hro-gaeste
auto hro-schzentrum
iface hro-schzentrum inet manual
       pre-up ip link add link eth1 name hro-schzentrum type vlan id 352
       up ip link set hro-schzentrum up
       post-down ip link del hro-schzentrum
auto hro-schnordost
iface hro-schnordost inet manual
       pre-up ip link add link eth1 name hro-schnordost type vlan id 353
       up ip link set hro-schnordost up
       post-down ip link del hro-schnordost
auto hro-schnordwest
iface hro-schnordwest inet manual
       pre-up ip link add link eth1 name hro-schnordwest type vlan id 354
       up ip link set hro-schnordwest up
       post-down ip link del hro-schnordwest
auto br-hro-beratung
iface br-hro-beratung inet manual
       bridge_ports hro-beratung
       bridge_stp off
auto br-hro-gaeste
iface br-hro-gaeste inet manual
       bridge_ports hro-gaeste
       bridge_stp off
auto br-hro-schzentr
iface br-hro-schzentr inet manual
       bridge_ports hro-schzentrum
       bridge_stp off
auto br-hro-schnordo
iface br-hro-schnordo inet manual
       bridge_ports hro-schnordost
       bridge_stp off
auto br-hro-schnordw
iface br-hro-schnordw inet manual
       bridge_ports hro-schnordwest
       bridge_stp off

Bereitstellung eines neuen Gateways / virtualisierter User-AP:

gastname="ap2-253"
version="0.5.3-unstable-1988"
#virsh destroy "$gastname"
#virsh undefine "$gastname"
mkdir -p "/tank/$gastname"
wget -O- "https://downloads.opennet-initiative.de/openwrt/testing/$version/x86/openwrt-$version-x86-generic-combined-ext4.img.gz"  \
   | gunzip >"/tank/$gastname/disk.img"
virt-install --connect qemu:///system -n "$gastname" -r 64 --vcpus=1 \
   --import --disk "path=/tank/$gastname/disk.img,format=raw,bus=sata" \
   --graphics vnc,keymap=de --serial pty --noautoconsole --os-type linux \
   --network=bridge:br1,model=e1000 --network=bridge:br-hro-schnordw,model=e1000 --hvm
virsh autostart "$gastname"
virsh console "$gastname"
## warten
uci set network.lan.ifname=none
uci set network.wan.ifname=none
uci set network.wan6.ifname=none
uci set network.on_eth_0.ifname=eth0
uci commit
on-function set_opennet_id 2.253

Anschließend per Webinterface:

  • Passwort und SSH Key setzen
  • Module installieren - on-captive-portal, on-monitoring, on-goodies, on-olsr2
  • Captive Portal - ON_FREE eth1 zuordnen
  • VPN Tunnel - Zertifikat für "Hansestadt Rostock" anfragen

ToDo

Links

Meine Werkzeuge
Namensräume

Varianten
Aktionen
Start
Opennet
Kommunikation
Karten
Werkzeuge